By continuing to use this site, you agree to our use of cookies. Find out more
Forum sponsored by:
Forum sponsored by CML

S6R receivers

New Frsky receiver with in-built stabilisation

All Topics | Latest Posts

Search for:  in Thread Title in  
Andrew Ray28/05/2017 20:10:53
avatar
703 forum posts
19 photos

Found the problem, I suspected it might be in the mixer, the setting I had was sticks and I needed to change to inputs, found it more by accident than design so not an S6R issue.

Jason Hyland04/06/2017 12:57:10
42 forum posts

Hi,

I'm trying to update the setting in my S6R using the latest LUA script (2.2.0), but it appears to "hang" on the 2nd page. I'be uploaded a video to demonstrate. Anyone have any ideas?

Reads OK using STK

Andy4804/06/2017 13:29:07
1358 forum posts
1 photos

Receiver needs to be powered up.

Jason Hyland04/06/2017 13:41:51
42 forum posts
Posted by Andy48 on 04/06/2017 13:29:07:

Receiver needs to be powered up.

Thanks Andy, I should have mentioned that it is

Jason Hyland04/06/2017 14:03:54
42 forum posts
Posted by Jason Hyland on 04/06/2017 12:57:10:

Hi,

I'm trying to update the setting in my S6R using the latest LUA script (2.2.0), but it appears to "hang" on the 2nd page. I'be uploaded a video to demonstrate. Anyone have any ideas?

Reads OK using STK

OK, appears that is requires the BETA firmare 170217 - thanks.

Jason Hyland04/06/2017 14:13:24
42 forum posts

OK, so now with the BETA firmware, CH12 no longer seems to do a "reset" or initialize. - has this chnaged do you know?

I don't know how long I've spent on this rx

Denis Watkins04/06/2017 15:01:09
3813 forum posts
54 photos

Some lads at the patch run these receivers from regular Futaba sets Jason and they are faultless, and it could be said they are easy. Taranis opens up the hobby in a big way and gives so many more options, so just keep plugging away.

Mike Blandford04/06/2017 15:43:07
avatar
522 forum posts
22 photos

To avoid CH12 accidently triggering the self check, the current requirement is CH12 changes 3 times away from and back to the centre position within 3 seconds.

OpenTx V2.2 has now been released. Ersky9x firmware also supports configuring the S6R from the transmitter.

Mike.

Mike Briant05/06/2017 08:16:58
avatar
20 forum posts
2 photos

Has anybody had problems with not being able to set up elevator rates? Aileron and rudder rates work fine but can't get elevator rates to work. Transmitter shows correct reaction on the graph but now change in the movement of the elevators.

Jason Hyland05/06/2017 08:38:22
42 forum posts
Posted by Mike Blandford on 04/06/2017 15:43:07:

To avoid CH12 accidently triggering the self check, the current requirement is CH12 changes 3 times away from and back to the centre position within 3 seconds.

OpenTx V2.2 has now been released. Ersky9x firmware also supports configuring the S6R from the transmitter.

Thanks Mike, I will test tonight, this makes sense to me. I'd tied the switch into my throttle enable so it wasn't active when throttle was, but this is probably double safe!

Jason Hyland05/06/2017 08:40:20
42 forum posts
Posted by Mike Briant on 05/06/2017 08:16:58:

Has anybody had problems with not being able to set up elevator rates? Aileron and rudder rates work fine but can't get elevator rates to work. Transmitter shows correct reaction on the graph but now change in the movement of the elevators.

Mike, probably know, but just in case - the only thing I found was that when you do your reset/initialize you need to have your full rates active otherwise it restricts what the rx puts out. ie, if you have low rates when you reset, the rx will never move them further - even when not in stab mode.

Mike Briant05/06/2017 08:48:44
avatar
20 forum posts
2 photos

Thanks Jason. Yes it was on full rates when I did the self test. Still doesn't seem to work for some reason. Hmmmmmmmm :/

Andrew Ray05/06/2017 10:23:04
avatar
703 forum posts
19 photos

Mike, I had a similar problem setting up my Horus and it was a problem with the way I had set up the mixer. On the mixer page I changed (I think) the inputs. Hopefully you will see something different if you compare the settings.

Mike Briant05/06/2017 11:51:30
avatar
20 forum posts
2 photos

Aaaaaah that's the answer. Thanks Andrew. Turns out that for the elevator you need to put the dual rates on the mixer page and not the inputs page. Strange that all the other controls work fine when you put the rates on the input page.

Chris Bott - Moderator05/06/2017 13:25:35
avatar
Moderator
6650 forum posts
1381 photos
1 articles

Mike the rates all work fine on the inputs page, I think you'll find there was some other issue.

Maybe on the mixer page you'd selected rudder and aileron inputs and ele stick? (Thereby ignoring the inputs page for ele?)

Mike Briant05/06/2017 14:21:31
avatar
20 forum posts
2 photos

Yes you're absolutely right Chris, I had. Duuuuuuuur me. Thanks to you and Andrew it's now working fine. Thanks chaps.

Chris Bott - Moderator05/06/2017 17:22:05
avatar
Moderator
6650 forum posts
1381 photos
1 articles

Good news then Mike.

That's an arguable downside of the incredible flexibility, you can actually do these things which cause problems or confusion down the line.

I find that I have just a few different model setups which I always copy for a new model and then tweak to suit.

For me, now, the fun is in dreaming up new functions in OpenTx, some of which would just be impossible in many other systems.

Andrew Ray05/06/2017 18:17:44
avatar
703 forum posts
19 photos
Posted by Chris Bott - Moderator on 05/06/2017 13:25:35:

Maybe on the mixer page you'd selected rudder and aileron inputs and ele stick? (Thereby ignoring the inputs page for ele?)

Thanks Chris, that's what I was getting at and was the problem I had when I converted my files from Taranis to Horus. It certainly is a challenge.

Edit. The files may have been like that on my Taranis and worked ok with an X8R but not the S6R once converted.

 

Edited By Andrew Ray on 05/06/2017 18:27:18

Mike Briant05/06/2017 18:31:54
avatar
20 forum posts
2 photos

Yes sorry Andrew, I misunderstood your first post, but you were both spot on so many thanks.

​Again you're right Chris, the flexibility of Taranis/Horus can be both a good and bad thing and something small can cause problems. I copy model setups too but in this case I fell into the trap of copying the error too. Thankfully though there's helpful chappies on here and youtube who know the answer to most questions. Someone, somewhere has had the same problem and found the answer.

Thanks again guys.

IanR15/06/2017 19:19:10
775 forum posts
4 photos

Has anybody else noticed how fragile the whisker portion of the antenna seems to be?

I bought an S6R from T9 recently and the whisker portion of one antenna seemed to angle itself to the remaining, covered, portion of the antenna as I moved it about, setting up etc. Sure enough, as I fitted it to my model, the whisker portion broke off. T9 replaced it n/c.

Now, the same thing is happening again, with one whisker showing a propensity to sit at an angle. I am not kack-handed and treated both antenna very gently.

Second question - can I just remove some of the covering from a broken antenna to make a new whisker on a now-shortened antenna?

All Topics | Latest Posts

Please login to post a reply.

Magazine Locator

Want the latest issue of RCM&E? Use our magazine locator link to find your nearest stockist!

Find RCM&E! 

Latest Forum Posts
Support Our Partners
Slec
Pepe Aircraft
Wings & Wheels 2019
Gliders Distribution
Addlestone Models
CML
Cambridge Gliding Club
electricwingman 2017
Sarik
Advertise With Us
Latest "For Sale" Ads
New Poll - Sticky situations...
Q: How often - when using superglue - do you end up with it on your fingers?

 Every time
 Occasionally
 Sometimes
 Rarely
 Never
 Wear rubber gloves

Latest Reviews
Digital Back Issues

RCM&E Digital Back Issues

Contact us

Contact us