By continuing to use this site, you agree to our use of cookies. Find out more
Forum sponsored by:
Forum sponsored by CML

Need urgent help with my 9D Plus update

All Topics | Latest Posts

Search for:  in Thread Title in  
RichB19/01/2018 21:10:34
84 forum posts
1 photos

I have attempted to update my recently purchased 9D Plus 2.1.6. I downloaded the Open Tx Companion and switched into Bootloader mode, connected the USB cable and now the Tx just shows USB Connected. I cannot switch the Tx off and my laptop just says USB device not recognised.

Help! What can I do to fix it?

Sorry if I have been a bit vague, but I am in a bit of a panic!

RichB19/01/2018 21:15:29
84 forum posts
1 photos

I have just tried the obvious of disconnecting the battery and it is now back to normal. I may just leave it at 2.1.6!!

Devcon119/01/2018 21:40:12
1411 forum posts
493 photos

I'm no expert but check your USB cable is data capable and not just a charge enabled one.

TigerOC19/01/2018 22:05:41
312 forum posts
13 photos

That is normal. The TX is in bootloader mode. The firmware update is done with the TX OFF using the Write firmware to radio option; 3rd from bottom icon on the left hand side task bar.

The bootloader is used to read/write model configurations to the radio.


Edited By TigerOC on 19/01/2018 22:06:47

Edited By TigerOC on 19/01/2018 22:07:32

RichB19/01/2018 22:07:45
84 forum posts
1 photos

Thanks for the replies. I'll give it another try.

Mike Blandford19/01/2018 22:15:44
629 forum posts
25 photos

No! The bootloader supports both flashing the firmware as well as reading/writing model data and reading/writing to the SD card.

In bootloader mode, when you plug in the USB cable you should see two hard drives appear on the PC.


Devcon119/01/2018 23:11:14
1411 forum posts
493 photos

is it possible to tell us the Companion Version you're using and what Firmware Version you were wanting to put on the X9D+. I wasn't sure if it had 2.1.6 or that was the version you wanted to put on it.

Andy4820/01/2018 14:30:45
1537 forum posts
9 photos

I seem to remember that Taranis sent out with 2.1.6 had a faulty bootloader on the system. Update this first then all should be well.

See here:


Go to the section called "The Basics".

RichB22/01/2018 14:02:32
84 forum posts
1 photos

I thought I had posted my thanks to all on Sunday, but that post hasn't appeared for some reason.

I would still like to say how much all the responses were appreciated.

I have now upgraded to 2.1.9 but had to do it in bootloader mode which raises another question. Do I always have to disconnect the battery to get out of bootloader mode?

Andy4822/01/2018 14:55:57
1537 forum posts
9 photos

No. Did you also upgrade the bootloader? If you upgraded through the bootloader, it would not update the bootloader itself. As I said the problem was probably the faulty bootloader.

While you are at it, you might as well go to OpenTX 2.2. There's a few extra twiddly bits make it worthwhile, and it gets harder to upgrade the more models you add onto the system sometimes due to some features changing slightly. For instance, on 2.2 the filelength for sounds and pictures has reduced to 6 characters from 7, so you have to go through your models and change the pictures and sound commands.

Edited By Andy48 on 22/01/2018 14:57:00

Devcon122/01/2018 15:01:15
1411 forum posts
493 photos

I don't think so. After entering boot loader mode and connecting to your PC, once you've finished whatever task you wanted to do you should safely eject the two drives from file manager then disconnect the USB, the Taranis screen should then give you a menu option to "exit" hit this and it should start up.

RichB22/01/2018 18:50:28
84 forum posts
1 photos

Andy48, I think you are correct that my bootloader is faulty, but nothing I'm trying will get it updated.

I've tried the routines suggested in the tutorials including YouTube but nothing seems to work. Any suggestions?

Andy4822/01/2018 19:00:33
1537 forum posts
9 photos

Look at the documentation I gave the link to above. That tells you how to update the bootloader. Its probably easier if you print it out. Use method 2 on page 10, but only update ther bootloader not all the firmware at this stage.

Given the fact your bootloader is probably faulty, its better to copy the files onto the SD card by taking the card out of the transmitter and putting it directly in the computer.

Once this is done, you can easily check the bootloader version number by going into the bootloader itself. If it has updated you should then be able to update firmwares normally. .... hopefully sarcastic 2

RichB22/01/2018 20:44:05
84 forum posts
1 photos

I've followed the instructions and removed the SD card. I've downloaded & copied the .bin file to the card and can then see it in the "Write Firmware" list when back in bootloader mode. If I then click on the "ENT" button it tells me to Hold ENT to start writing. If I do this it says "Writing Complete" but it is still at Bootloader 2.1.6. I've tried it several times with the same result.

I'm now getting frustrated with the darn thing.

Any further ideas?

Andy4823/01/2018 11:29:22
1537 forum posts
9 photos

Ah! "can then see it in the "Write Firmware" list when back in bootloader mode" There is your problem. The bootloader cannot update itself whilst it is being used.

If you read the documentation carefully, to update just the bootloader, you load the firmware onto the SD card as you have done, and then switch on the Taranis normally and update the bootloader. Go to page 10 of the documentation and follow steps 7 and 8.

Its easy really. wink

RichB23/01/2018 21:13:04
84 forum posts
1 photos

Doh! I can't believe how many times I've read that bootloader can't be updated when in bootloader mode and there I was trying to do just that!

It took a few seconds when I got home and worked as it should (of course).

Once again, many thanks for your help. It really is much appreciated.

Andy4824/01/2018 16:00:25
1537 forum posts
9 photos

Glad it worked. Invoice in the post. smile p

All Topics | Latest Posts

Please login to post a reply.

Latest Forum Posts
Support Our Partners
Sussex Model Centre
electricwingman 2017
Advertise With Us
Latest "For Sale" Ads
Has home isolation prompted you to start trad' building?
Q: The effects of Coronavirus

 Yes - for the first time
 Yes - but Ive bashed balsa before
 No - Ive existing projects on the bench
 No - Im strictly an ARTF person

Latest Reviews
Digital Back Issues

RCM&E Digital Back Issues

Contact us

Contact us

Magazine Locator

Want the latest issue of RCM&E? Use our magazine locator link to find your nearest stockist!

Find RCM&E!