By continuing to use this site, you agree to our use of cookies. Find out more
Forum sponsored by:
Forum sponsored by CML

Screaming electric motor

All Topics | Latest Posts

Search for:  in Thread Title in  
Stephen farrar14/06/2018 15:14:37
11 forum posts

Hi, just installed a new replacement motor in my wing wing. Tested without propellor and all worked fine. But, when I put on the propellor and gave it full throttle the motor stopped and made a screaming noise. No burning smell or smoke. Removed propellor, gave it full throttle and all is okay. Tried with propellor, 5 x 5, engine stops at full throttle with screaming noise again, tried without prop and all okay, tried with 6 x 5 propellor, screaming noise at full throttle again with engine stop. Anybody any ideas as I'm stumped.

Denis Watkins14/06/2018 15:17:20
3493 forum posts
165 photos

Timing Stephen. Check the paperwork for setting the timing

Or

The outer casing could be spinning on the shaft under load

There is often an Allen screw to tighten

Edited By Denis Watkins on 14/06/2018 15:18:59

Gary Manuel14/06/2018 15:23:04
avatar
1791 forum posts
1507 photos

If it's screaming, it sounds like the motor is spinning at high revs, but the prop isn't. Check that the prop adapter is gripping the motor shaft.

Stephen farrar14/06/2018 15:23:39
11 forum posts

Hi Denis, thanks for the quick reply. Unfortunately I'm not sure what you mean. I only replaced the motor like for like and the new motor did not come with any paperwork.

Stephen farrar14/06/2018 15:27:29
11 forum posts

Hi Gary, prop retained with one of those prop saver rings and it is gripping ok. Motor doesn't scream when no prop is on and that would be at its highest revs I presume.

Graham R14/06/2018 15:44:49
302 forum posts
19 photos

Thought I read somewhere that you shouldn’t run up a brushless without a prop on it.

Stephen farrar14/06/2018 15:45:11
11 forum posts
Hi Denis, The motor isn't spinning at all when the screaming noise starts, it stops completely.
Stephen farrar14/06/2018 15:48:48
11 forum posts
Hi Graham, not seen that myself but it runs okay at full revs without the prop, not with, the motor completely stops when prop attached.
Kim Taylor14/06/2018 15:54:37
236 forum posts
53 photos
Posted by Stephen farrar on 14/06/2018 15:45:11:
Hi Denis, The motor isn't spinning at all when the screaming noise starts, it stops completely.

Single phased, perhaps, or a burned out or dodgy winding.

Check the motor - esc connections to make sure they're sound.

Kim

All Topics | Latest Posts

Please login to post a reply.

Magazine Locator

Want the latest issue of RCM&E? Use our magazine locator link to find your nearest stockist!

Find RCM&E! 

Latest Forum Posts
Support Our Partners
Gliders Distribution
electricwingman 2017
Pepe Aircraft
Slec
Revoc
Wings & Wheels 2018
CML
Motion RC
Advertise With Us
Sarik
Latest "For Sale" Ads
Does your club have a safety officer?
Q: Does your club have a safety officer, or is the emphasis on individual members to each be their own safety officer?

 Yes we have a SO
 No, it's down to everyone

Latest Reviews
Digital Back Issues

RCM&E Digital Back Issues

Contact us

Contact us