By continuing to use this site, you agree to our use of cookies. Find out more
Forum sponsored by:
Forum sponsored by CML

Phoenix and Win10

It will not work, do I throw it away?

All Topics | Latest Posts

Search for:  in Thread Title in  
i12fly27/07/2018 21:14:18
avatar
564 forum posts
21 photos

After a number of years of non use I tried to load Phoenix version 2.5 onto my pc running Windows 10 home 64bit system with Direct X 12. (To be honest that means nothing to me... )

It seemed to load OK, but gave error 1721 which was cured by FAQ and help from my son.

However now it loads onto the pc, opens 'choose language' and stops at that point, it will not let me choose language or anything.

Can anyone advise how to fix it or is it just scrap?

If its dead any recommendations for replacement on a relatively low budget would be much appreciated.

Denis Watkins27/07/2018 21:37:38
3913 forum posts
61 photos

Keep going with the Phoenix, it upgrades for life, provided you have a legal copy and original dongle

TRY, opening Phoenix online, and proceed to use it and then it will ask for your disk

Put your disk in, and follow the instructions, if any

i12fly28/07/2018 00:06:50
avatar
564 forum posts
21 photos

Hi Denis, I'll try that tomorrow. It is a legal copy and I've still got the dongle

Alan H28/07/2018 10:27:31
76 forum posts
2 photos

This link might help:-

https://www.helifreak.com/showthread.php?t=725757

Plummet29/07/2018 18:25:23
avatar
1403 forum posts
41 photos

To confirm, the download works. I have it on 'doze 10

Plummet

i12fly29/07/2018 21:32:43
avatar
564 forum posts
21 photos

After the umpteenth try (and getting page not found either starting from Phoenix downloads or helifreak I finally managed to download version 5.0 (from Phoenix downloads), then it asked me if I wanted 5.5 so downloaded that too. I thought I was OK -but no. Trying to open Phoenix it said it couldn't because 'X3DAudio1-7.dll' was not found.

A little bit of googling showed that it is missing from Win10 but I could download it -so I did.

Still no joy, when trying to load Phoenix it gives the same cannot find 'X3...… '

Can anyone tell how to tell it to find it? I copied it to the same folder as Phoenix but still same error......

Denis Watkins29/07/2018 21:54:29
3913 forum posts
61 photos

Wow Fly, look how far you have come from initially scrapping version 2.5, now you are up to 5.5, well done.

Carry on while I research X3 Daudio, as I have no idea

But in the meantime

Get your X3 audio logo visible, and right click upon it.

Near the bottom right of the info there are a couple of tick boxes, one says read only.

Either way, tick both boxes, then untick both boxes to leave them clear

And below, the option to APPLY will become available

Click apply and OK

Now try loading Phoenix again

Read this page carefully too

https://www.lifewire.com/fix-x3daudio1-7-dll-not-found-or-missing-errors-2624292

 

Edited By Denis Watkins on 29/07/2018 21:57:52

Brian Dorricott 129/07/2018 22:20:03
83 forum posts
2 photos

If it's any help .DLLs should go in one the system folders i.e. c:\windows\ system(system32 if 32 bit) not in the program folders as the pointers in the program tend to look in the system folders for DLL files . Do a search for .DLL files and look where they mainly are on your machine and drop a copy in there as well won't do any harm anyway . If it works Bob's your mother's brother and if it doesn't then I have only wasted a minute of your time - computers are only as bright as the idiots that write the software !

i12fly30/07/2018 21:27:06
avatar
564 forum posts
21 photos

So near yet so far....I tried right click properties ticked and unticked the attributes and applied. Still gave same error.

Tried searching for the .dll files, there were 34K+ and seemed to be in many locations, so then tried c:\windows\system32. Found many, many folders in there had a look through there but couldn't see anywhere logical to put it. Thought I'd try and paste it directly into system32, but it said I'd need administrator permissions (or password - I can't remember) to make the change. Strange as it is a home pc and no administrator as far as I'm aware. At that point blood pressure was starting to rise like a fizzing lipo so I cancelled.

Have read the link you gave Denis, I'll try that process another day starting from scratch.

Slickriff30/07/2018 22:19:33
48 forum posts
1 photos
On a home pc (unless the shop were naughty and put a password on it so you have to go back to them) it usually says that you need administrator permissions and you click OK and it gives you them. Very pointless, but I have seen it a good many times.
Kim Taylor30/07/2018 22:30:28
285 forum posts
53 photos

I seem to remember I had this problem - if you look on the Phoenix Flight Sim support page here **LINK** at the bottom of the page there;s a reference to missing.dll files.

I did what they suggest and it worked for me.

Kim

Edited By Kim Taylor on 30/07/2018 22:30:53

i12fly07/08/2018 23:48:49
avatar
564 forum posts
21 photos

Well thanks to the advice from you guys and the encouragement, tonight I managed to successfully upgrade my Phoenix to version 5.0. Much of the way was mental torture (well I'm exaggerating a bit here) but it was relief in the end.

Success was gained by uninstalling Phoenix, getting rid of everything I could find connected with it.

Reload my 2.5 version, and update to version5 from the Phoenix website. Note that it seems the download link will not work at weekends -I downloaded last night, no problem at all.

Using the Phoenix Support page, first the Error 1721 was sorted, then the missing dll file. Phoenix then detected a direct X problem but gave the required link.

Everything seemed fine, it loaded, set up the old Futaba 6EXA Tx but then Argh! the ailerons would not work, stuck on left roll. Repeated Tx set up -still the same, so tried my 35MHz Futaba 7C -and it worked just fine. I just need to upgrade to 5.5 now and fiddle with the system settings so they're how I like them.

As Denis suggested in another thread, set to keep the ground in view is much better I don't feel 'airsick' now.

Thank you all for your help

Denis Watkins08/08/2018 10:59:15
3913 forum posts
61 photos

Tenacity is the name of your game Fly, Well Done

All Topics | Latest Posts

Please login to post a reply.

Magazine Locator

Want the latest issue of RCM&E? Use our magazine locator link to find your nearest stockist!

Find RCM&E! 

Latest Forum Posts
Support Our Partners
Wings & Wheels 2019
Gliders Distribution
electricwingman 2017
Pepe Aircraft
Cambridge Gliding Club
CML
Slec
Sarik
Advertise With Us
Latest "For Sale" Ads
Do you use a throttle kill switch?
Q: This refers to electric-powered models but do you use a throttle kill switch?

 Yes
 No
 Sometimes
 Rarely

Latest Reviews
Digital Back Issues

RCM&E Digital Back Issues

Contact us

Contact us