By continuing to use this site, you agree to our use of cookies. Find out more
Forum sponsored by:
Forum sponsored by CML

Spektrum iX12

Servo Settings

All Topics | Latest Posts

Search for:  in Thread Title in  
Pickygit04/09/2018 09:32:12
avatar
12 forum posts
10 photos

I'm having trouble setting up matching servo travel for flaps and as this is my first Spektrum radio cannot for the life of me see where I'm going wrong.

Wing type: 2 Ailerons: 2 Flaps.

This is the set up for the flaps:-
Channel Input Configuration:-
Channel 8 - Aux 3 - Switch E (3 position)
Channel 9 - Aux 4 - N/A

RX Port Assignment:-
Channel 8 - Aux 3 - Right Flap.
Channel 9 - Aux 4 - Left Flap.

Tried setting the travels on each servo and cannot get them to move the same amount. Is this something to do with Channel 9 Input Configuration being N/A?

Thanks

Denis Watkins04/09/2018 09:40:58
3877 forum posts
59 photos

The size of the increments of travel and trim can be set on most channels

Go through as you found, there is a discrepancy on the channels you are using

Don Fry04/09/2018 11:08:08
avatar
3920 forum posts
42 photos

Are you using switch E to move the flaps? If so you need to assign Switch E to channel 9 as well, so switch E is switching both channels, and hence both servos.

Pickygit04/09/2018 12:49:59
avatar
12 forum posts
10 photos
Posted by Denis Watkins on 04/09/2018 09:40:58:

The size of the increments of travel and trim can be set on most channels

Go through as you found, there is a discrepancy on the channels you are using

Hi Denis. Thanks for that but can you give me any guidance on the location of this facility? I can't see any options that do this in the Model Setup screens.

Pickygit04/09/2018 12:55:38
avatar
12 forum posts
10 photos
Posted by Don Fry on 04/09/2018 11:08:08:

Are you using switch E to move the flaps? If so you need to assign Switch E to channel 9 as well, so switch E is switching both channels, and hence both servos.

Hi Don. Yes, I've set Ch. 8 to SW E but am unable to select the same option in Ch. 9. However, SW E is operating both servos, it's just that the one in Ch. 9 does not replicate the same movement as the servo in Ch. 8. Channels 1 - 7 and 9 have all been automatically set to 'N/A' by the transmitter. I assume that this has been pre-defined when I set the wing type to '2 Ailerons - 2 Flaps'.

Chris Walby04/09/2018 13:06:22
avatar
981 forum posts
230 photos

Most likely unrelated, but I was playing around with my lowly DX8g1 and mixes when I had the same sort of issue. I had reduced the travel on one of the aux channels which produced the effect where the channels would not follow each other.

Hope that helps

Denis Watkins04/09/2018 15:01:52
3877 forum posts
59 photos

Woops, I jumped in as my DX6 a Trim Setup

Trim Setup,

Model Utilities.

Use The Trim Setup Screen To Change The Size Of The Trim Step And The Trim Type.

I just assumed that the mighty 12, would have the same facilty

John Lee04/09/2018 15:21:54
653 forum posts
48 photos

On my Dx9 I don't have any switch allocated in the Channel Input Config menu.

It's allocated in Function List-Flap System-Switch. You use the same menu (Flap System) to adjust the Throw & Elevator Compensation mixing. Hope that helps, afraid I've not used an iX12.

All Topics | Latest Posts

Please login to post a reply.

Magazine Locator

Want the latest issue of RCM&E? Use our magazine locator link to find your nearest stockist!

Find RCM&E! 

Latest Forum Posts
Support Our Partners
electricwingman 2017
CML
Cambridge Gliding Club
Gliders Distribution
Pepe Aircraft
Wings & Wheels 2019
Slec
Advertise With Us
Sarik
Latest "For Sale" Ads
New Poll - Sticky situations...
Q: How often - when using superglue - do you end up with it on your fingers?

 Every time
 Occasionally
 Sometimes
 Rarely
 Never
 Wear rubber gloves

Latest Reviews
Digital Back Issues

RCM&E Digital Back Issues

Contact us

Contact us