By continuing to use this site, you agree to our use of cookies. Find out more
Forum sponsored by:
Forum sponsored by CML

Latent Servo Response

Technical problem?

All Topics | Latest Posts

Search for:  in Thread Title in  
MAD Dave11/01/2019 11:29:41
92 forum posts
9 photos

I experienced something new yesterday which pretty much wrote off my second electric powered Pulse XT60.

What happened is described below. Has anyone else had a similar experience please and know what the cause and/or fix might be?

I was enjoying my second flight of the day with the aircraft and practicing stall turns. I was lucky in that I was accompanied by an experienced club member who was able to witness the pattern of events and confirm it wasn’t down to me.

On the third stall-turn pull up, I thought I may have perceived a short delay between commanding up elevator and the model actually entering a climb. At the time, “Is it me?” was my first thought. All other control responses appeared fine. So I flew an orbit of the field and tried again. No, it wasn’t me, it did it again and with a slightly increased delay. On attempting an asap landing, I intermittently lost elevator authority and into the tree tops it went. I do not know whether I simultaneously lost aileron/rudder/engine, it was flying straight and level at the time and no deviation was required so no other stick movements were made.

A challenging tree-top recovery was aided by three fine club colleagues and a still functioning downward facing motor. This act rendered a largely intact fuselage but, sadly, the wings were written off. As power was still applied, I immediately exercised the elevator. No mechanical problems, no delay, working fine. I am at a bit of a loss to understand the chain of events. The club’s flying field is located in “Darkest Dorset”, well away from known radio frequency transmitters.

Radio gear was Futaba, Tx, T6J and Rx, R2006GS, and I’d left my mobile phone in my car. I had flown two other models earlier using the same Tx and not experienced any problems. Tx battery volts were well within spec. throughout.

Any helpful suggestions or clues would be very much appreciated; I have a slight preference to avoid a repeat!

Finally, I am devastated having severely damaged my second Pulse XT 60, it was my favoured model and I had hoped to take my BMFA “B” with it. I understand it is no longer in production so if anyone has a spare pair of wings they would be happy to part with, I would be most grateful. Please drop me a line and we can talk terms!

My first Pulse XT60? Hands up, my fault, wrong model set on transmitter………..

Caveman11/01/2019 12:06:36
311 forum posts
244 photos

Hi Dave, whilst I can't offer any suggestions at to your lack of elevator response, I can make a suggestion ref. a new set of wings for your Pulse XT 60.

When an attack of dumb-thumb reduced my Hobby King Soar 40 from this

HK Soar 40

to this


I dissembled the wreckage, produced a set of plans,


and built a replica of the original, using all the original hardware. It flies just as well as the original plane.

It's not difficult to do as you can see how the original was made and mimic it.

As you only need the wings it shouldn't take too long.

Food for thought?

Cheers GDB

The Wright Stuff11/01/2019 12:14:00
1382 forum posts
226 photos

I have seen latent servo motion in some of my older planes (thankfully picked up in the pre-flight check). I swapped out the servos and it went away. Latent action on the ground (at zero range) is pretty definitely not a loss of radio signal, though in your case I guess it's not quite so easy to make this distinction.

Draw your own conclusions, but likely to be either the servo feedback pot dirty or worn, or dodgy connections.

I have never seen the issue with new servos.

Steve Balaam11/01/2019 12:22:36
137 forum posts

I would check my flight battery. As the battery starts to get to minimum under load the servo's will slow down before stopping altogether when the battery fails. I've had this a number of times over the years.

Simon Chaddock11/01/2019 12:24:22
5777 forum posts
3055 photos

It can be frustrating but I would put in down to a temporary loss of signal or poor servo connection.

The actual cause may now be difficult to trace as everything has now been given a substantial "shake".

All you can do is make sure everything follows good practise principles when you rebuild and maybe use a different Rx..

Nigel R11/01/2019 12:25:38
4090 forum posts
694 photos

Can't think of anything bar a problem with power to servo. Not sure how a dirty pot would produce the lag? But if power was only intermittently making it to the servo it would explain the issue.

Only seeing the issue on the elevator servo suggests the servo but as posted above the RX battery is worth checking (or replacing), the elevator servo might have been more sensitive to a low voltage - is it the same type as the rest?

Edited By Nigel R on 11/01/2019 12:29:56

alex nicol11/01/2019 12:43:08
395 forum posts
17 photos

Hi Dave,

it's one of the worst things that can happen, as without an absolute definitive reason it destroys your confidence in your radio gear.

If you're absolutely sure the txt is ok, then the only real thing you can do is scrap the all the radio gear in the plane

Alternately you could scrap the elevator servo and try again.........but if the fault isn't in the servo then chances are it'll happen again

It's a tough one. I've had the misfortune of wrecked airframe due to what I thought was a faulty servo.......repaired the airframe, replaced Servo and then suffered a total loss

good luck with whatever you decide

Cuban811/01/2019 13:14:17
3035 forum posts
1 photos

Absolute nightmare scenario. If it were me, and I was convinced that it wasn't pilot error, a problem with the tranny or a sneaky mechanical fault,  then I think the only useful thing to do is to change the airborne system, RX, elevator servo and all its wiring, battery and switch harness. Essentially what we have is a guessing game with not very good odds that you'll be right without hard and fast, repeatable evidence. Might cost a few quid to get some replacement gear, but stack that against another smashed model and still being none the wiser. If you have missed something (none of us are infallible) and you do pin the problem down, you'll always have the extra gear for another model.

Edited By Cuban8 on 11/01/2019 13:15:56

Don Fry11/01/2019 13:49:46
4557 forum posts
54 photos

I had an own design 6 foot hack, designed to take different engines, fly nicely in any conditions. Good it was too. It went in. Everything was tested to death. It was put down to, but not proven, to a switch. Then a second one went in. Plan built for an 80. A glow motor job, and it went to failsafe. (First was petrol, and they stop on loss of power, or signal). It was the receiver, new, expensive, high end piece of scrap, going to fail safe every hour or so.

I never found out what was wrong, because I took out my frustration and anger at it and myself by jumping up and down on it until it was mashed into the gravel path. That's about 400 hours of work lost.

Not trusted goes in the bin. You know it makes sense.

Brian Hammond11/01/2019 16:38:12
357 forum posts

Sometimes it,s a good idea to unplug everything and then replug ,it makes sure there is a good connection and that the plugs have not worked loose, I used to be a tv repairman and so often customers said their Rc handsets had failed but just take the batteries out and put them back in and very often all would be well.

Martin Harris11/01/2019 16:46:22
9505 forum posts
256 photos

As I read your description, my immediate thought was "receiver battery" as suggested by a couple of people.

Do you have one or are you using a BEC?

If you do, it could be that the battery voltage recovered slightly while the servos were inactive - test would be to give the servos a good workout (before recharging) preferably while monitoring the battery voltage but otherwise seeing if the servos start to slow after some work.

If you're using a BEC, one of the servos could be binding or faulty, dropping the voltage prematurely and affecting the others. Alternatively, the BEC might be affected by heat from the ESC and might be shutting down. Again, test under load on the ground to see if you can reproduce any of these effects.

MAD Dave11/01/2019 17:13:47
92 forum posts
9 photos

Many thanks for your contributions so far Gents, lots for me to consider. I did wonder about contact resistance, at the plugs/sockets. I had your point in mind Brian and started to wonder about dis and reconnecting everything as an occasional routine maintenance activity on all my airframes. The Pulse has been stored in my (integral to the house) garage over the winter so far. Not perhaps the greatest of storage environments but less damp and cold than some other places. I have not tested anything since returning from our flying field, just parked the remains in the hanger for now. Tx is always kept indoors. I use a BEC integral with the ESC Martin, the whole is in the line of a good airflow. I don't know what the generally accepted life of servo is, the Futaba examples I am using are about six years of age; maybe it is time to ditch them? That said, I have some Fleet servos of several years age that still work fine! Wondering also whether I should use a separate NiMh battery pack?

MattyB11/01/2019 17:47:10
2225 forum posts
32 photos

Posted by Cuban8 on 11/01/2019 13:14:17:

Absolute nightmare scenario. If it were me, and I was convinced that it wasn't pilot error, a problem with the tranny or a sneaky mechanical fault,  then I think the only useful thing to do is to change the airborne system, RX, elevator servo and all its wiring, battery and switch harness. Essentially what we have is a guessing game with not very good odds that you'll be right without hard and fast, repeatable evidence.

I think the OP should certainly do some basic testing before junking his entire airborne system, which seems a bit of an over-reaction at this point...

From the symptoms I would say the most likely cause is a  power supply issue of some sort. Could be the contacts to the elevator servo, or perhaps the BEC or even switch went u/s in flight. What type of BEC is it (switiching or linear?), what max continuous amp rating was it, and how many servos (and of what type) was it supplying?

Suggested next steps.

  • Test the BEC on the ground - get all 4 servos running off a servo tester supplied by the BEC, then let it run for a period to see if it fails. You could even insert a Y lead so you can monitor the BEC voltage under load using a multimeter (though if it's a switching BEC you may get some transient results related to the sample rate of the multimeter vs. the BEC switching)
  • Examine all the contacts on the RX, servos and BEC carefully for corrosion. If any signs, replace that connector (for servos/BEC leads - be carefult to check the corroion has not gone back up the wire) or in the case of the RX the whole thing.
  • If there is a switch in the circuit, test and replace (or get rid of it altogether) - Most RC switches are cheap things with a nasty habit of failing over time, particularly when stored in cold damp conditions. If in doubt, replace.

Edited By MattyB on 11/01/2019 17:49:46

Cuban811/01/2019 17:59:21
3035 forum posts
1 photos

Dave, in 45 years of R/C flying, I've only ever seen one of my own genuine Futaba servos fail on one occasion. I must have, and continue to use dozens of them and have only had one single definite servo failure (broken gears not included) - an FP-S128 IIRC, that glitched the ailerons like mad when you opened the throttle because of a broken solder joint at the pot. Easily repaired, in fact I still might have the servo tucked away somewhere. Nearly cost me a model, but managed to keep control by pulling back to idle and landing PDQ. I'd be very surprised if it was a servo at fault, but it's not impossible of course.

Its actually a good idea sometimes, to leave it a while before going over a fault, so that the old brain can clear and the initial shock of the crash subsides. The problem is that you dare not try the airborne pack again in flight, but can only try to reproduce the fault on the ground - and simply taking a chance is not really making the flight 'being reasonably confident that it can be made safely (BMFA handbook, or words to that effectwink). Power supply inefficiency is a good candidate, but unless you are equipped and knowledgeable enough to test it, then just change it for a good battery and test thoroughly. What you describe about the initial delay in servo response does sound like what happens with a failing battery, so maybe your BEC was beginning to shut down. I think it's worth investigating that before much else. MattyB's procedure is spot-on.

Apologies if I gave the impression that you should junk your system without a second thought, of course not, I'm not made of money myself, but if you really can't pin the problem down to your complete satisfaction to give peace of mind, then you won't be the first to have to go down that route, as frustrating as that is.

Good luck.




Edited By Cuban8 on 11/01/2019 18:28:14

Steve J11/01/2019 18:25:42
2063 forum posts
60 photos
Posted by MAD Dave on 11/01/2019 17:13:47:

I use a BEC integral with the ESC Martin, the whole is in the line of a good airflow.

While it could be anything in the line from the transmitter to the servo, the BEC overheating or simply not being able to supply the required current would be top of my list.

I would always advise using a separate UBEC or battery to power the receiver and servos in a model of this size.


Edited By Steve J on 11/01/2019 18:26:19

MAD Dave12/01/2019 00:39:08
92 forum posts
9 photos

Thank you everyone for your thoughts, much for me to think about now....................... dont know

Frank Skilbeck12/01/2019 08:56:57
4824 forum posts
107 photos

If it was only the elevator servo and all other controls were fine then it falls into two categories

1) fault in elevator servo

2) fault in elevator control in the Tx

You can discount 2 if it only affects this plane and all others are OK. Interestingly I "fixed" an intermittent servo in my old Wildthing yesterday, it has old Fleet servos fitted (yes it's that old) and I'd made up some converter leads as Fleet used a different pin order, turned out that the signal wire was making poor contact in the converter lead, I removed the servo plug and fitted a new one, it works perfectly now (well at least on the bench, going to fly it today)

Cuban812/01/2019 11:20:26
3035 forum posts
1 photos

I've had servo extension leads that over time, have given intermittent servo operation, manifested by sluggish servo movement when commanded, and obvious 'hunting' when centering. Output arm will be easy to push off centre with your finger. Sometimes, after the model hadn't been used for a while, the problem would occur briefly and then go away, sometimes it would gradually improve over a minute or so and then act normally. Disconnecting and remaking the plug/socket 'cures' the problem and all goes back to how it should be, at least for a while.  Easy to miss on a quick pre-flight stick waggle surprise .

Had this with genuine manufacturers' parts and copies.



Edited By Cuban8 on 12/01/2019 11:53:33

All Topics | Latest Posts

Please login to post a reply.

Support Our Partners
electricwingman 2017
Sussex Model Centre
Advertise With Us
Latest "For Sale" Ads
NEW POLL - has the pandemic altered your event safety perceptions?
Q: Has the covid pandemic deterred you from attending shows and events in 2021?

 No, I'll be attending just as many as I usually do
 No, but I'll choose my event with greater care
 Yes, I'll attend fewer events going forward
 Yes, I wont attend any where previously I have

Latest Reviews
Digital Back Issues

RCM&E Digital Back Issues

Contact us

Contact us

Magazine Locator

Want the latest issue of RCM&E? Use our magazine locator link to find your nearest stockist!

Find RCM&E!