By continuing to use this site, you agree to our use of cookies. Find out more
Forum sponsored by:
Forum sponsored by CML

Eflite 60amp esc

All Topics | Latest Posts

Search for:  in Thread Title in  
DIGGER19/04/2019 08:27:14
131 forum posts
4 photos

I have a problem that I can't figure out. I have a brand new Eflite 60amp esc (EFLA1060C ) that I wanted to use in a model but it won't start the motor. The rx is the Apprentice S one EFLR310013 and the motor is Turnigy , the controls all work but no motor, it don't even play any tunes. If I put an eflite 40amp esc on it works ok. The 60amp is not faulty it was tested , can anyone explain this.

Chris

Gordon Tarling19/04/2019 09:24:40
227 forum posts
4 photos

Common reasons for this problem -

1 - plug at receiver end is wrong way round, but if servos work, it's probably not this.

2 - Throttle channel is reversed.

3 - Throttle channel pulsewidth is too high to initialise the ESC - try reducing it with either trim or subtrim.

4 - can you try the ESC with another motor?

DIGGER19/04/2019 16:07:04
131 forum posts
4 photos

Hi Gordon

(1) your right nothing would work, all leads double checked. (2) throttle channel is not reversed again double checked. (3) tried the trim setting on the transmitter right down to the lowest setting still dead. (4) red it with 3 other motors including an eflite motor same results. Thanks for your help, this may be one for Spektrum technical department. It's got me stumped, especially that just putting a 40amp esc on the same setup and it works. There must be something in the 60amp esc that stopping it, BUT WHAT?

Chris

Capt Kremen19/04/2019 16:17:39
avatar
260 forum posts
63 photos

Can you operate / test the ESC using a WattMeter (i.e. LiPo-ESC-Motor with No Prop)?

I have occasionally found the 'range' available on these meters allows otherwise recalcitrant ESC to operate!

DIGGER19/04/2019 16:23:52
131 forum posts
4 photos

Capt Kreme, No haven't tried that, I'll see tomorrow if I can do that. Thanks .

Chris

Dickw19/04/2019 16:26:13
avatar
420 forum posts
70 photos

From the manual:-

"Troubleshooting ………….. If you have trouble arming the controller (and the throttle trim has been set to minimum), enter the programming mode and try changing the set-ting to 1.1ms to 1.9ms in Programming Menu 4 to see if it helps correct the problem. If it is a computer radio, you may alternatively increase high and low throttle ATV (endpoint) percentages. Note: Increasing the high ATV will not have a consequence on arming issues, only low ATV."

I suggest going into programming mode and try setting up the ESC endpoints again.

Dick

Kim Taylor19/04/2019 17:12:40
250 forum posts
53 photos

The apprentice receiver won't 'talk' to all esc's, not even all Eflite ones.

The normal getaround is to put a switch in the signal wire, to let the receiver do it's dance before enabling the esc, although in my experience, this doesn't always work.

I got over it in one application by using a separate rx battery and cutting the red wire from the esc to the rx.

There's a lot more info on RCGroups in the thread 'Eflite SAFE Rx in another plane' in the electric plane talk forum.

hth

Kim

Kim Taylor19/04/2019 18:26:26
250 forum posts
53 photos

Cut & paste from an earlier thread may be of use..........

I've got a Max Thrust Riot (Devil) which I wanted to fit my old Apprentice receiver to, but the esc was having none of it.angry

In essence, I believe that the reason some esc's won't arm with the apprentice receiver is that the esc looks for a throttle low signal to arm it (presumably within a certain, but unknown to me, time frame). However the Apprentice receiver doesn't give this arming signal until the control surfaces have done their 'dance' which takes 10 seconds or more from switch on.

Having done a bit of research, I tried a couple of techniques which others have found to work. Before doing any of the following, REMOVE THE PROP!!!

1. Set up the throttle range using another receiver first, then connect the Apprentice receiver - this had absolutely no effect on my setup, although some have had success.

2. Remove the +ve lead from the lead connecting the esc and the Apprentice receiver throttle port. Arrange a separate power supply via the bind port of the receiver. Switch on your tansmitter and power the receiver up BEFORE connecting the lipo to the esc. Set throttle high, then plug in the lipo. You will get the tones from the esc, then lower the throttle, at which point it will arm and you will have full control of the throttle. Disconnect the lipo, then switch off the receiver, followed by the transmitter. Replace the +ve wire previously removed and plug into the throttle port. Switch the tranny back on, connect the lipo then switch on the receiver. With luck, you've got full control still and your problem is solved. This technique is often successful, apparently. In my own case, however unplugging the lipo caused the esc to 'forget' the settings and the problem was still evident.

3. Provide a separate switched supply to the receiver, Permanently remove the +ve wire from the esc to the receiver and connect everything up. The start up sequence MUST be tranny on, receiver switch on (wait for dance to finish) THEN connect the lipo. Eureka!!! It works.

So a bit of a faff and probably not ideal but with throttle cut set it's safe enough I think even if (as in my case) the lipo has to be loaded from beneath the nose. An arming plug would give a second level of safety, which I may well do in due course.

As I said, much more info here (be warned, there's a lot of it!!).

**LINK**

Kim

DIGGER24/04/2019 07:46:17
131 forum posts
4 photos

, I must apologise for not getting back on this thread , I haven't been able to get out and try your ideas out yet. Will let you know when I can get out there.

Chris

All Topics | Latest Posts

Please login to post a reply.

Magazine Locator

Want the latest issue of RCM&E? Use our magazine locator link to find your nearest stockist!

Find RCM&E! 

Latest Forum Posts
Support Our Partners
Motion RC
Revoc
electricwingman 2017
Slec
Gliders Distribution
Pepe Aircraft
Wings & Wheels 2019
CML
Sarik
Advertise With Us
Latest "For Sale" Ads
Does your club have a safety officer?
Q: Does your club have a safety officer, or is the emphasis on individual members to each be their own safety officer?

 Yes we have a SO
 No, it's down to everyone

Latest Reviews
Digital Back Issues

RCM&E Digital Back Issues

Contact us

Contact us