By continuing to use this site, you agree to our use of cookies. Find out more
Forum sponsored by:
Forum sponsored by CML

SkyRC D100 V2 AC/DC Dual Balance Charger Charging Problem

All Topics | Latest Posts

Search for:  in Thread Title in  
Tosh McCaber19/01/2020 11:38:38
24 forum posts
5 photos

I purchased a SkyRC D100 V2 AC/DC Dual Balance Charger just over a year ago. I haven't done a lot of power flying over the past few years, so the charger has not been used very often.

Due to unavoidable events, I haven't managed to get on to the flying field since Autumn. However, earlier today, I decided to charge my LiPo battery packs, which have been stored inside in flame-proof baggies. All have voltages of around 80% full charge. Plugged the charger to the mains, connected a couple of 2.2mah 3S packs in on balanced charge, and they topped up nicely.

Immediately aftere they were fully charged, I then plugged the next two- a 2.2a 3S and a 1.8mah 3S into the charger. Same procedure- I pressed the Start button- the lady in the machine tells me to- "Select cells/ select current/ press and hold enter button to start/ Battery Check comes up on display, then / press Start to confirm"- then a nasty "NO POWER DISTRIBUTED" display appears. I then tried a couple more batteries, unfortunately, same result.

On page 36 of the Instruction Manual, it tells me that "No Power Distributed" means "No power allocate to charger". I don't know what that signifies, since there obviously is power in the charger! Other than repeating what the Charger is telling me, unfortunately, in the instruction manual, there is no explanation, nor remedy!

I've tried Discharge for a minute or two, which seems to act OK. But I'm baffled as to why the first two batteries charged as they should, but the others won't charge.

To date, the charger has behaved exactly as it should, but I'm at a loss as to why this has suddenly happened. I wonder if you may be able to throw light on what's going on? Failing anyone being able to help, is there is anywhere in the UK where I can send it to have it checked? I don't particularly want to bin an expensive piece of kit!

Any thoughts gratefully received!

Denis Watkins19/01/2020 12:46:37
4082 forum posts
77 photos

Double check Tosh, your mains plug, for tight wire connector screws

And the wall socket

Of try another mains socket

Dickw19/01/2020 12:47:57
avatar
563 forum posts
79 photos

It sounds like all your attempts have been with two packs at a time. Have you tried charging a single battery on its own? Try a single battery, but try both outputs separately to see if it is just one output that is a problem.

Dick

Frank Skilbeck19/01/2020 13:22:16
avatar
4576 forum posts
101 photos

Never seen this message on mine which has been in continuous service for the last 18 months. You can go into the menu and allocate how much power you'd like allocating to each charging circuit and the 12v power supply, could you have accidentally amended this.

Tosh McCaber19/01/2020 15:18:46
24 forum posts
5 photos

Thanks guys.

Dennis- I've checked the (moulded) mains plug- ail fine. Tried it on another wall outlet- no difference- still not working!

Dickw- Tried it with a single battery pack- no difference for both battery outlets

Frank- Hmm- I've done some more investigating- When I switch to "Storage", the process starts. But this is because I think that it's discharging, rathert than charging? Not sure about allocatiing power?

Triying any of the charging modes comes up with the same message- " No Power Distributed" Grrr!

The charger is working, except it won't charge!! Grrr!

Dickw19/01/2020 15:44:44
avatar
563 forum posts
79 photos

Have you looked at the power allocation settings yet, as suggested by Frank?

You could try re-loading the factory default settings if all else fails.

No idea why anything would have changed, but obviously something has.

Dick

Tosh McCaber19/01/2020 16:51:52
24 forum posts
5 photos

Not sure about allocatiing power, Dick? I reloaded the factory settings- Unfortunately, no joy!

Could the internal power supply/ component have failed- suddenly?? Goodness knows- cant even see how the box opens up? Presumably the lid comes off- held by two screws? Not that I intend to fiddle about with it!!

Tosh McCaber19/01/2020 16:55:54
24 forum posts
5 photos

Can anyone tell me how to arrive at power settings? Although I've a sneaky suspicion that having reset to factory settings, it won't make any difference?

Frank Skilbeck19/01/2020 17:04:13
avatar
4576 forum posts
101 photos

In the systems settings menu the first screen should show how many watts are allocated to the DC supply and Ch1 and Ch2, normally this should be DC Supply OFF, channel 1 and channel 2 50w each. If they aren't then enter this menu and change them.

The other thing you could try if you suspect the power supply (but I'm not sure why you'd get the menus if it didn't power up) would be to connect a DC supply (e.g. 3s/4s lipo) to the DC input and see if it then works.

Tosh McCaber19/01/2020 18:44:57
24 forum posts
5 photos

Frank- I think that youi've cracked it! - For some reason, (and without my bidding!) when I went into system settings on CH1, the DC reading was 100%. I knocked it down to 0, the power supply reading for both Channels 1 and 2 went from 0 up to 50W, and tried again. It's started charging- back to normal!!?

Thanks for all you guys' help- now I've just to master the menu on this infernal charger!

By the way Frank, it's Jim Anderson here from Aberdeen and District Soarers- long time no see!

Edited By Tosh McCaber on 19/01/2020 18:45:38

Frank Skilbeck19/01/2020 19:06:08
avatar
4576 forum posts
101 photos

Jim, glad I could help, lovely to hear from you, it's 30 years since I left Aberdeen and ADS. Have seen Norrie a couple of times on the Mynd.

All Topics | Latest Posts

Please login to post a reply.

Magazine Locator

Want the latest issue of RCM&E? Use our magazine locator link to find your nearest stockist!

Find RCM&E! 

Latest Forum Posts
Support Our Partners
electricwingman 2017
Sussex Model Centre
Cambridge Gliding Club
Slec
CADMA
CML
Wings & Wheels 2019
Sarik
Advertise With Us
Do you use a throttle kill switch?
Q: This refers to electric-powered models but do you use a throttle kill switch?

 Yes
 No
 Sometimes
 Rarely

Latest Reviews
Digital Back Issues

RCM&E Digital Back Issues

Contact us

Contact us