By continuing to use this site, you agree to our use of cookies. Find out more
Forum sponsored by:
Forum sponsored by CML

Confused about OTX version

All Topics | Latest Posts

Search for:  in Thread Title in  
Allan Bennett13/07/2020 13:51:06
1701 forum posts
49 photos

I understand the difference between FrSky firmware and OTX firmware, but I'm still a bit confused about the latter, and how it gets onto my Taranis:

My OTX Companion is definitely v2.3.9, which I understand is the latest version. But when I go to the 'Version' menu in my Taranis is says it's '2.3.0 (2c018e71)' date '2019-09-05 08-55-07' eepr '219'

My Taranis X9D+ 2019 has been updated to v2.1.0, confirmed in its firmware screen, but is my OTX version correct?

Andy4813/07/2020 14:18:00
1549 forum posts
10 photos

No. You need to update it to 2.3.9. You've updated Companion but not the transmitter.

Allan Bennett13/07/2020 14:58:42
1701 forum posts
49 photos

Thanks Andy. I've just followed a U-tube video and now my trannie OTX and bootloader are both 2.3.9. I do this so rarely, I'd forgotten what needed to be done frown

All Topics | Latest Posts

Please login to post a reply.

Support Our Partners
electricwingman 2017
Slec
CML
Sussex Model Centre
Sarik
Advertise With Us
Latest "For Sale" Ads
Has home isolation prompted you to start trad' building?
Q: The effects of Coronavirus

 Yes - for the first time
 Yes - but Ive bashed balsa before
 No - Ive existing projects on the bench
 No - Im strictly an ARTF person

Latest Reviews
Digital Back Issues

RCM&E Digital Back Issues

Contact us

Contact us

Magazine Locator

Want the latest issue of RCM&E? Use our magazine locator link to find your nearest stockist!

Find RCM&E!