By continuing to use this site, you agree to our use of cookies. Find out more
Forum sponsored by:
Forum sponsored by CML

Faulty AR500 receiver

second time around

All Topics | Latest Posts

Search for:  in Thread Title in  
Peewhit29/09/2009 19:18:22
avatar
795 forum posts
264 photos
Hi folks,
 
A couple of months back my AR500 receiver developed a fault after only about ten hours use in a slope soarer
 
Every time it powered up it went into bind mode.
 
Those nice chaps at Horizon Hobby replaced it for me very quickly - their service really is excellent.
 
Guess what, the replacement has developed the same fault after only a few hours in the air - a bit frustrating when you find this out on the slope.
 
Anyone else had a similar experience or is this just my bad luck?
 
Only a two channel SAS Fusion but this time it's going to get a AR6200 -  I have had two of these for over a year with no problems at all
Tim Mackey29/09/2009 19:33:51
avatar
20914 forum posts
304 photos
15 articles
Nope, never.
Are you sure you are following the bind procedure and subsequent boot up procedure EXACTLY as per instructions?
Explain word for word how you do it, and we will see what we can suss
Peewhit30/09/2009 19:25:00
avatar
795 forum posts
264 photos
Hi Timbo,
 
The receiver initially bound without problem following the usual procedure - bind plug in battery/bind port, power to another port (led flashing), switch on transmitter (DX7) with bind button held in (led solid) remove bind plug and power off receiver, power off transmitter.
 
Tip of the long aerial is at 90 deg to the short one. Tx set to delta wing, battery (via switch) to battery port, left aileron in aileron port and right in elevator port.
 
I always power on the Tx before the Rx, and turn the Rx off first.
 
Everything was fine for several outings then suddenly one day the Rx went into bind mode immediately on power up (just like the last one) and will not rebind.
 
Horizon concluded that the last one had developed a fault and therefore replaced it.
 
Seems to me that the replacement has developed exactly the same fault.
 
Ernie30/09/2009 19:32:48
avatar
2509 forum posts
20 photos
Years ago, I bought a power drill from B&Q...It broke after about two minutes. They replaced it without question. After two minutes the new one broke. Replaced again, and again etc. 
There was a fault in the batch

ernie
Tim Mackey30/09/2009 19:39:19
avatar
20914 forum posts
304 photos
15 articles
Hmm, interesting - sounds like you are doing everything correctly - indeed you may have a duff one / two
Peewhit30/09/2009 19:50:03
avatar
795 forum posts
264 photos
Thanks anyway.
 
Have somewhat lost confidence in the AR500 - AR6200 on the way to replace it
Brian Parker30/09/2009 20:20:05
538 forum posts
Peewhit, 
Out of interest are you re-binding the receiver with the servo plugs disconnected (ie. with just bind plug and power lead as per initial bind) or are servos still connected.
If still connected then perhaps you have signal to ground leakage through a (faulty) servo. This may fool the receiver into bind mode.
 Just a thought and clutching straws.
Tim Mackey30/09/2009 22:37:26
avatar
20914 forum posts
304 photos
15 articles
A few more straws.... it is definately entering ind mode is it - and not merely displaying flashing LEDS to indicate brown out??
If it is entering bind mode, then you will, of course have no control, whereas if you do still have control, its a brown out scenario instead.
Peewhit02/10/2009 20:26:48
avatar
795 forum posts
264 photos
Definitely entering bind mode as opposed to brown out.
 
Thought about a servo possibly shorting it out.
 
Have tried to re-bind with no servos connected at all - no success - just willnot bind.
 
Thanks anyway chaps - think the packet of straws is starting to run out.
 
AR 6200 arrived today - set it up with no problems at all
Lee Smalley02/10/2009 20:43:09
avatar
2125 forum posts
68 photos
2 articles
im with you peewhit the only problems i have ever had with the spektrum stuff have been with AR500 i will not buy another one!!
Peewhit03/10/2009 19:30:59
avatar
795 forum posts
264 photos
So it's not just me then, Lee.
 
It is worth the extra cost of the AR6200.
Lee Smalley03/10/2009 22:20:29
avatar
2125 forum posts
68 photos
2 articles
yes defo never had prob with any other spekky stuff but AR500  1 lost bind mid flight (immpossible i had horizon say)  well the model did not go into fail safe battery was on 6.8 volts when checked, when i found the reciever it powered up fine but was unbound and i had to rebind reciever and everything worked, range check was fine  horizon swapped it anyway, had another that would brown out and not reconnect after 10 seconds (its supposed to be milliseconds) stick with anything else and you will be fine

All Topics | Latest Posts

Please login to post a reply.

Magazine Locator

Want the latest issue of RCM&E? Use our magazine locator link to find your nearest stockist!

Find RCM&E! 

Latest Forum Posts
Support Our Partners
Pepe Aircraft
Wings & Wheels 2019
electricwingman 2017
Revoc
Slec
CML
Motion RC
Gliders Distribution
Advertise With Us
Sarik
Latest "For Sale" Ads
Does your club have a safety officer?
Q: Does your club have a safety officer, or is the emphasis on individual members to each be their own safety officer?

 Yes we have a SO
 No, it's down to everyone

Latest Reviews
Digital Back Issues

RCM&E Digital Back Issues

Contact us

Contact us